Delays in AU Direct Debit billing
Incident Report for Ezypay
Resolved
All delayed AU Direct Debit transactions have been processed, and the incident is now resolved.
Posted May 02, 2023 - 16:25 AEST
Monitoring
Impacted transactions have been submitted to our banking partner, and are awaiting processing in line with regular DE batch processing cycles. We will be monitoring these transactions to ensure they are processed as expected within the next several hours.
Posted May 02, 2023 - 15:22 AEST
Investigating
We are currently experiencing a delay with processing Direct Debit (Bank) transactions in Australia. Direct Debit transactions due to be processed on 1st May have been delayed. We are working with our banking partner to get these transactions processed as soon as possible.
Posted May 02, 2023 - 12:36 AEST
This incident affected: Backend Payments & Settlement (Bank Direct Debit billing).