HQ Online Sign Up Unavailable
Incident Report for Ezypay
Resolved
HQ Online Sign Up issue has been resolved; Earlier report of outage was in error, and no incidents or outages affecting the Ezypay platform.
Posted Jul 22, 2024 - 10:36 AEST
Investigating
We're currently investigating an issue that is impacting HQ Online Sign Up in AU. During this time you may experience "An Error occurred while processing your request" with the Online Sign Up Link. We will provide an update as soon as we can.
Posted Jul 22, 2024 - 10:06 AEST
This incident affected: Customer & Payment Method Management (Customer payment method management, Customer Management, Plan & Subscription Management).