Card Billing Issue affecting several regions - AU, MY, SG, HK, TW

Incident Report for Ezypay

Resolved

This incident has been resolved.
Posted Apr 22, 2025 - 05:33 AEST

Monitoring

Our downstream provider has managed to resolved the root cause of the issues affecting card transactions in Australia, Malaysia, Singapore, Hong Kong and Taiwan. Ezypay, along with our downstream provider, will continue to monitor closely to ensure that no further issues are encountered.
Posted Apr 22, 2025 - 05:22 AEST

Identified

We are currently experiencing an elevated rate of errors with processing Card transactions in Australia, Malaysia, Singapore, Hong Kong and Taiwan. Card transactions in other regions are unaffected. Transactions on payment methods other than Card are also unaffected.

We are working with our downstream provider to resolve this issue urgently, and will provide further updates as soon as possible.
Posted Apr 22, 2025 - 04:54 AEST
This incident affected: Backend Payments & Settlement (Card Billing), Payment Initiation (Ezypay scheduled billing initiation, Partner initiated on-demand billing), and Customer one-off payment (checkout.ezypay.com, paynow.ezypay.com).