Elevated rate of errors with card transactions in the Philippines
Incident Report for Ezypay
Resolved
We've been able to reconcile our platforms state against our downstream providers to a satisfactory level, and we've re-enabled the processing of card transactions in the Philippines as a result. Our queued transactions have been processed successfully, and we are now operating as normal in the Philippines. As per previous updates, transactions in regions other than the Philippines were unaffected, and continue to be unaffected.

We will continue monitoring the situation closely. For any concerns, please reach out to help@ezypay.com .
Posted Sep 02, 2023 - 23:53 AEST
Update
We have received some data from our downstream providers, and we are reconciling against Ezypay's data. There appears to be some minor discrepancies which we are investigating prior to re-enabling card processing in the Philippines. We expect to be able to provide an update in the next 3 hours.

All transactions in all other regions are unaffected, and may be processed as per usual.
Posted Sep 02, 2023 - 19:51 AEST
Update
Unfortunately we are still awaiting data from our downstream provider, to allow us to do the full reconciliation on transactions processed through our provider throughout the incident window which will enable us to safely re-enable our processing. Our priority is to ensure that customers aren't inadvertently charged twice, and as such we will continue to queue up card transactions in the PH until we are confident that we can release them to our downstream provider.

All transactions in all other regions are unaffected, and may be processed as per usual.
Posted Sep 02, 2023 - 07:59 AEST
Update
We are still experiencing an issue with our downstream card provider in the Philippines. Whilst the original root cause appears to be resolved, we are awaiting some data to allow us to do a full reconciliation on transactions processed through our provider throughout the incident window to enable us to safely re-enable our processing.


All transactions in all other regions are unaffected, and may be processed as per usual.

We will provide further updates at https://status.ezypay.com/ as soon as possible.
Posted Sep 01, 2023 - 20:49 AEST
Identified
We are currently experiencing an elevated rate of errors with processing Card transactions in the Philippines. We are working with our downstream provider to resolve this issue urgently.

As a precaution, we have suspended all card transaction processing for the Philippines. Scheduled billing for card transactions will be resumed once our downstream provider has resolved their underlying issue.

Although new payment requests (invoices) submitted to Ezypay for the Philippines will be queued and processed once the issue is resolved, we recommend not sending new payment requests for the Philippines to Ezypay where feasible, until we have confirmed the issue is resolved.

All transactions in all other regions are unaffected, and may be processed as per usual.

We will provide further updates at https://status.ezypay.com/ as soon as possible.
Posted Sep 01, 2023 - 19:16 AEST
This incident affected: Backend Payments & Settlement (Card Billing), Payment Initiation (Ezypay scheduled billing initiation, Partner initiated on-demand billing), and Customer one-off payment (checkout.ezypay.com, paynow.ezypay.com).