Card Billing Issue

Incident Report for Ezypay

Resolved

All queued payments have been processed, and real-time payment processing has returned to normal.

The platform has remained stable during monitoring, and no further issues have been observed. This incident is now resolved.
Posted Jul 02, 2026 - 17:54 AEST

Monitoring

A hotfix has been implemented, all queued payments have been processed, and real-time payment processing has resumed without further delays or issues.

The incident is currently being monitored to ensure stability.
Posted Jul 02, 2026 - 16:25 AEST

Update

Backlogged payments have been processed successfully; however, card transactions continue to experience delays.

Troubleshooting remains ongoing, and we will provide further updates as progress is made.
Posted Jul 02, 2026 - 15:30 AEST

Investigating

We are currently experiencing a significant delay with card transactions.

Our teams are working on this issue as a matter of urgency, and we will provide further updates as soon as possible.
Posted Jul 02, 2026 - 14:00 AEST
This incident affected: Payment Processing (Australia, New Zealand, Malaysia, Singapore, Philippines, Hong Kong, Taiwan, South Korea).