HQ is currently unavailable due to a hardware failure
Incident Report for Ezypay
Resolved
The incident has been resolved. All affected services migrated to another host and the original host issue has been rectified.
Posted Sep 16, 2021 - 21:51 AEST
Investigating
Currently experiencing a hardware failure. Our third party vendor is investigating the issue
Posted Sep 16, 2021 - 19:55 AEST